Informationen
-
Dieser Modul-Workflow
-
baut auf dem im Tutorial: Modul-Customizing (Level 1) erstellten Modul auf.
-
beschreibt weitere Modul-Customizing-Möglichkeiten.
-
-
Das Arbeiten mit diesem Workflow setzt die Kenntnisse voraus, die im Tutorial: Modul-Customizing (Level 1) vermittelt wurden.
Erstellen eines einfachen Terminplans
Termindatenfelder einfügen
Ziel
-
Im Modul Testmodul sollen Vorgangs-Termin-Datenfelder im Fenster 2 angezeigt werden.
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Die folgenden Dataitems einfügen:
-
001113 Wunsch-Anfang
-
001114 Wunsch-Ende
-
001119 Kalk. Anfang
-
001120 Kalk. Ende
-
-
Für die neuen Datenfelder im Feld Fenster den Wert 2 auswählen.
-
Für die Datenfelder Kalk. Anfang und Kalk. Ende im Feld DF-Verhalten den Wert o auswählen.
-
Speichern.
Kalenderlistboxen für Termindatenfelder hinterlegen
Ziel
-
Für die Felder Wunsch-Ende und Wunsch-Anfang im Vorgangsbereich soll über die Funktion Calendar Control ein Kalender hinterlegt werden
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Für das Datenfeld Wunsch-Ende im Feld DF-Verhalten den Wert cc auswählen.
-
Dialogmeldung Möchten Sie ein Template für das cc-Datenfeld einkopieren? mit Ja bestätigen und die Art des Templates auswählen.
-
Speichern.
-
Das ausgewählte Template wird automatisch in das Datenfeld Datenfeld-Konfiguration einkopiert.
-
Die Parameter im Feld Datenfeld-Konfiguration können anschließend bei Bedarf angepasst werden.
-
-
Das gleiche für das Datenfeld Wunsch-Anfang durchführen.
-
Speichern.
Beispiel
def_start_date = 01.01.1970
def_end_date = 31.12.2099
calendar= @G150
xaml = <StackPanel
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml">
<toolkit:Calendar xmlns:toolkit="clr-namespace:Microsoft.Windows.Controls;assembly=WPFToolkit"
Name="Calendar"
Margin ="0,-3,0,-2">
</toolkit:Calendar>
</StackPanel>
Einbinden eines Skalenbereichs
Ziel
-
Erstellen eines Skalenbereichs durch das Kopieren eines bestehenden Skalenbereichs und Einbinden in das Modul Testmodul
Skalenbereich kopieren
-
Im Modul Module Klick mit der rechten Maustaste auf die Modulnummer.
-
Einfügen → Datenbereichszuordnung aus dem Kontextmenü auswählen.
-
Eine leerer Datenbereichs-Datensatz wird eingefügt.
-
-
Klick auf den Link Keine Bezeichnung im Feld Datenbereich.
-
Das Modul Datenbereiche wird aufgerufen.
-
-
In das Datenfeld DA die Nummer des zu kopierenden Skalenbereichs, z.B. 040833, eintragen.
-
Mit Drag&Drop-Kopieren → Datensätze den Datenbereich kopieren.
-
Speichern.
Skalenbereich einfügen und strukturieren
-
Die Identnummer des gerade angelegten DAs in das Datenfeld DA im Modul Module kopieren.
-
Das Feld Maßstab aus F9 einblenden und den gewünschten Maßstab eintragen (z.B. 8).
-
Zum Strukturieren den Datenbereich Projekt mit SHIFT + Ziehen mit der linken Maustaste auf den neu erstellen Skalenbereich ziehen und loslassen. Somit wird der Objektbereich dem Skalenbereich untergeordnet. Ergebnis der Struktur:
-
Skala
-
Projekt
-
Vorgang
-
-
-
-
Die Felder Pos. und Oberbereich entsprechend der im Modul angezeigten Struktur füllen.
-
Damit die Skala fest angezeigt wird, den Parameter Feste Überschrift aktivieren und Überschrift deaktivieren.
-
Speichern.
Für Fenster 3 Breite definieren
-
Das Modul Datenbereiche schließen.
-
Im Modul Module Klick auf die Schaltfläche
Weitere Modulparameter anzeigen oder Alt+P.
-
Das Modul Weitere Modulparameter wird geöffnet.
-
-
Im Feld Breite F3 eine Breite für Fenster 3 eingeben, z.B. 800.
-
Speichern.
Einbinden von Balken
Ziel
-
In den Vorgangsbereich Balken einbinden für
-
Wunsch-Termine
-
kalkulierte Termine
-
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Folgende DIs einfügen:
-
002001 Balken: Wunsch-Termine
-
002951 Balken: Kalkulierte Termine
-
-
Für beide Balkendatenfelder folgende Parameter definieren:
-
Fenster = 3
-
DF-Verhalten = ba
-
-
Speichern.
Modul testen
-
Das Modul Testmodul neu starten.
-
Unter der Skala werden im Vorgangsbereich die Balken der Wunsch- und der kalkulierten Termine angezeigt.
Tooltip customizen
Ziel
-
Für den Wunsch-Termin-Balken einen Tooltip festlegen
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Für das Datenfeld 002001 Balken: Wunsch-Termine in das Feld Tooltip den gewünschten Text einfügen, z.B.:
Start: @startDateH(dd.MM.yy)
Ende: @endDateH(dd.MM.yy)
Dauer: @wdDuration Tage
-
Speichern.
Modul testen
-
Das Modul Testmodul neu aufrufen.
-
Fährt man unter der Skala mit der Maus über einen Wunsch-Termin, wird der Tooltip mit den entsprechenden Daten angezeigt.
Balkenhilfsfelder customizen
Ziel
-
Zu dem Balken der kalkulierten Termine ein Balkenhilfsfeld z.B. den Vorgangsnamen anzeigen lassen
-
Ein Balkenhilfsfeld ist ein Feld, das z.B. neben dem Balken unter der Skala angezeigt wird.
-
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Im Standard ist die Python-ID für alle Dataitems vergeben.
-
Wird ein individuelles Balken-Dataitem verwendet, muss das Datenfeld DF-Python-ID gefüllt werden.
-
-
Das Feld 000807 Vorgangsbezeichnung ein zweites Mal einfügen.
-
Hinweise:
-
Ein Datenfeld kann entweder als Datenfeld im Modul oder als Balkenhilfsfeld angezeigt werden. Soll es beides sein, muss das Datenfeld dem Datenbereich zweimal zugeordnet werden.
-
Wird für ein Balkenhilfsfeld im Datenfeld Fenster 1,2 oder 3 eingetragen, erscheint das Balkenhilfsfeld im Fenster 3. Wird Fenster =9 definiert, ist das Balkenhilfsfeld unsichtbar.
-
-
-
In die Modulvariante Balken wechseln.
-
Für das neu eingefügte Feld VG-Name im Parameter Balkenlink (DF-Python-ID) die Python-ID des Balken-Datenfelds eintragen (hier: bar_ta_cd_trlt).
-
Im Parameter Andockpunkt die Position des Balkenhilfsfelds definieren z.B. 1 Startpunkt ist Balkenende.
-
In die Modulvariante Layout wechseln und im Datenfeld DF-Breite eine Breite für das Balkenhilfsfeld Vorgangsbezeichnung vergeben z.B. 600.
-
Im Feld DF-Verhalten o auswählen.
-
Speichern.
Modul testen
-
Modul Testmodul neu aufrufen
-
Am Ende des Balkens der kalkulierten Termine wird die Vorgangsbezeichnung angezeigt.
Hinweise
-
Werden einem Balken mehrere Balkenhilfsfelder zugeordnet, die am Balkenende angezeigt werden sollen, können diese in der Modulvariante Layout über die X/Y-Positionen positioniert werden.
-
Die Einbindung von Ampeln auf Balkenhilfsfeldern ist möglich.
Grafisches Anlegen, Ändern und Verschieben von Balken ermöglichen
Ziel
-
Grafisches Anlegen, Ändern und Verschieben des Balkens Balken: Wunsch-Termine im Datenbereich Vorgang ermöglichen
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
In die Modulvariante Balken wechseln.
-
Für das Balkenfeld 002001 Balken: Wunsch-Termine die folgenden Checkboxen aktivieren
-
Speichern.
Modul testen
-
Das Modul Testmodul starten.
-
Die Wunsch-Termin-Balken können unter der Skala grafisch angelegt, geändert und verschoben werden.
Vorgänge strukturiert anzeigen
Ziel
-
Vorgänge strukturiert anzeigen
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen.
-
Dem Datenbereich folgende Dataitems in Fenster 9 zuordnen:
-
001097 Projekt-ID
-
008851 ID übergeordneter Vorgang
-
001098 Vorgangs-ID
-
-
-
Im Parameter Rekursive Relation folgendes hinterlegen: N:1,DI001097:DI001097,DI008851:DI001098.
-
Dadurch werden die Vorgänge entsprechend ihrer Werte in den DIs ID übergeordneter Vorgang und Vorgangs-ID strukturiert dargestellt.
-
-
Speichern.
AOB-Datenbereich anlegen
Ziel
-
Anlegen und Einbinden eines AOB-Datenbereichs
Bestehenden AOB-Bereich kopieren
-
Im Modul Module Klick mit der rechten Maustaste auf die Modulnummer.
-
Einfügen → Datenbereichszuordnung aus dem Kontextmenü auswählen.
-
Ein leerer Datenbereichs-Datensatz wird eingefügt.
-
-
Klick auf den Link Keine Bezeichnung im Feld Datenbereich.
-
Das Modul Datenbereiche wird aufgerufen.
-
-
In das Datenfeld DA die Nummer des zu kopierenden DAs, hier 040272, eintragen.
-
Mit Drag&Drop-Kopieren → Datensätze den Datenbereich kopieren.
-
Speichern.
Hinweis
-
Das DI006920 Vernetzung AOB/Balkenplan2 stellt die AOB unter der Skala als blaue Verbindungslinie dar.
AOB-Bereich dem Modul zuordnen und strukturieren
-
Die Identnummer des gerade angelegten DAs in das Datenfeld DA im Modul Module kopieren.
-
Zum Strukturieren den AOB-Datenbereich mit SHIFT + Ziehen mit der linken Maustaste auf den Datenbereich Vorgang ziehen und loslassen. Somit wird der AOB-Datenbereich dem Datenbereich Vorgang untergeordnet. Ergebnis der Struktur:
-
Skala
-
Projekt
-
Vorgang
-
AOB
-
-
-
-
-
Die Felder Pos. und Oberbereich entsprechend der im Modul angezeigten Struktur füllen.
-
Im Feld Baum 1 auswählen.
-
Beim Aufruf des Moduls soll die AOB in der Tabelle (in Fenster 1) zugeklappt angezeigt werden, den Parameter Anzeige = 0 bzw. leer (Nicht Anzeigen) setzen.
-
In Fenster 3 wird die AOB weiterhin angezeigt.
-
-
Speichern.
Modul testen
-
Das Modul Testmodul starten.
-
Die AOBs werden unter der Skala angezeigt und können ebenfalls in der Tabelle (Fenster 1) durch Aufklappen des Baums angezeigt werden.
Grafisches Anlegen von AOBs ermöglichen
Ziel
-
Grafisches Anlegen von AOBs ermöglichen
Vorgehensweise
-
Den Datenbereich Vorgang aufrufen und die Modulvariante Balken auswählen.
-
Für das Datenfeld 002951 Balken: Kalkulierte Termine die Checkbox Balken verlinken aktivieren.
-
Speichern.
Modul testen
-
Das Modul Testmodul neu starten.
-
Die AOBs können grafisch angelegt werden.
Datenbereiche über Relationen verbinden
Ziel
-
Im Modul Testmodul soll unter der Projektmaske die Ressource des Projektmanagers angezeigt werden
Information
-
Die Datentabellen DT461 Projekt und DT467 Ressource sind nicht über Relationen miteinander verbunden.
Ressourcen-Datenbereich anlegen und dem Modul zuordnen
-
Modul Module aufrufen und die Identnummer des Moduls Testmodul eingeben.
-
Einen leeren Datensatz für den neuen Datenbereich einfügen durch:
-
Klick auf den vorhandenen Datenbereich und Betätigen des Buttons Einfügen in der Symbolleiste.
-
oder Klick mit der rechten Maustaste auf den vorhandenen Datenbereich und Auswählen Einfügen → Datenbereichszuordnung.
-
-
Klick auf den Link Keine Bezeichnung im Feld Datenbereich.
-
Das Modul Datenbereiche wird aufgerufen.
-
-
Einen neuen Datenbereich mit folgenden DIs aus der DT467 Ressource anlegen:
-
DDI = 001218 Ressourcen-ID
-
DIs:
-
001218 Ressourcen-ID
-
001275 Ressource
-
-
-
Speichern.
-
Den neu angelegten Ressourcen-Datenbereich durch Kopieren der Datenbereichsnummer per Drag&Drop dem Modul zuordnen.
-
Modul Datenbereiche schließen.
Datenbereiche strukturieren und Relation setzen
-
Zum Strukturieren den Ressourcendatenbereich mit SHIFT + Ziehen mit der linken Maustaste auf den Datenbereich Vorgang ziehen und loslassen. Somit wird der Ressourcendatenbereich dem Datenbereich Vorgang untergeordnet. Ergebnis der Struktur:
-
Skala
-
Projekt
-
Vorgang
-
Ressource
-
AOB
-
-
-
-
-
Die Felder Pos. und Oberbereich entsprechend der im Modul angezeigten Struktur füllen.
-
In die Modulvariante Verbindungen wechseln.
-
In der Datenbereichszuordnung des Ressourcen-Datenbereichs in das Datenfeld Relation zu Oberbereich folgendes eintragen: 1:N,DI001218:DI001062. Dabei sind DI001218 Ressource, DI001062 Manager.
-
Dadurch wird pro Projekt die Ressource, die dem Projektmanager entspricht, angezeigt.
-
-
In die Modulvariante Basis wechseln.
-
Im Feld Baum 1 auswählen.
-
Speichern.
Tipp
-
Verbindungen zwischen Datenbereichen funktionieren auch mit unvollständigen Schlüsseln (z.B., wenn ein untergeordneter Datenbereich der DT463 zugeordnet ist, deren Primärschlüssel aus zwei Feldern besteht; der übergeordnete Datenbereich hingegen der DT461 zugeordnet ist, deren Primärschüssel aus nur einem Feld besteht).
Modul testen
-
Das Modul Testmodul neu starten.
-
Die Ressource des Projektmanagers wird unter der Projektmaske angezeigt.
Modulvariante anlegen
Ziel
-
Anlegen einer Modulvariante, in der
-
der Ressourcendatenbereich nicht angezeigt wird
-
im Vorgangsdatenbereich zusätzliche Felder angezeigt werden
-
Modulvariante anlegen
-
Den Datenbereich Vorgang aufrufen.
-
Die folgenden DIs einfügen:
-
DI059007 Meilenstein: Text
-
DI001488 Spannvorgang
-
-
Für die neuen Datenfelder im Feld Fenster den Wert 9 auswählen.
-
Die Checkboxen in den Feldern Filterkriterien und DF-Optionen aktivieren.
-
Speichern.
-
Das Modul aufrufen.
-
Die neu eingefügten Datenfelder in Fenster 1 einblenden.
-
Klick auf die Schaltfläche
im Modulreiter.
-
Klick auf Modulvariante erstellen und eine Bezeichnung für die neue Variante eingeben.
-
Bei der Eingabe für eine Bezeichnung erscheint rechts vom neuen Eintrag das Pfeilsymbol
zum Anlegen und Speichern der neuen Variante.
-
-
Das Pfeilsymbol oder die Taste Return betätigen.
-
Extras -> Optionsmodul für MV aufrufen.
-
Für den Bereich Ressource den Parameter Nie anzeigen aktivieren
-
Das Optionsmodul für MV schließen.
-
Im Modulreiter in der Modulvarianten-Listbox auf das Speichersymbol klicken.
Information
-
Damit jeder Benutzer die Modulvariante sieht und verwenden kann, muss die individuelle Modulvariante in eine Standardmodulvariante umgewandelt werden.
Modulvariante freigeben (in Standardvariante umwandeln)
-
Im Modul Module das Feld Benutzer-MV anklicken.
-
Für die entsprechende Modulvariante im Feld Benutzer den Benutzer löschen.
-
Speichern
Modul testen
-
Das Modul Testmodul neu starten.
-
In der Listbox im Menü kann in die neu angelegte Modulvariante gewechselt werden.
Zum Modul-Customizing-Tutorial (Level 3)
Information
-
Modul-Customizing-Tutorial (Level 3) gibt einen ersten Einblick in das Customizing mit Python.
|
Siehe auch : Weitere Customizing-Funktionen |